PAT A 1046 Shortest Distance

The task is really simple: given N exits on a highway which forms asimple cycle, you are supposed to tell the shortest distance between anypair of exits.

Input Specification:

Each input file contains one test case. For each case, the first linecontains an integer N (in [3, 10^5^]), followed by N integer distancesD~1~ D~2~ ... D~N~, where D~i~ is the distance between the i-th and the(i+1)-st exits, and D~N~ is between the N-th and the 1st exits. All thenumbers in a line are separated by a space. The second line gives apositive integer M (<=10^4^), with M lines follow, each contains apair of exit numbers, provided that the exits are numbered from 1 to N.It is guaranteed that the total round trip distance is no more than10^7^.

Output Specification:

For each test case, print your results in M lines, each contains theshortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 100010;
int a[maxn], dis[maxn];    //数组很大,要定义在主函数外面,否则会出错
int main() {
	int N, i, sum = 0;
	scanf("%d", &N);

	for (i = 1; i <= N; i++) {
		scanf("%d", &a[i]);
		sum += a[i];
		dis[i] = sum;    //dis[i]标识第一个节点到第i+1个节点的距离
	}
	
	int M;
	scanf("%d", &M);
	int fir, sec;
	for (i = 1; i <= M; i++) {
		scanf("%d %d", &fir, &sec);
		if (fir>sec) swap(fir, sec);    //节点下标要从小到大,不是则交换
		int temp = dis[sec - 1] - dis[fir - 1];
		printf("%d\n", min(temp, sum - temp));
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/80529432