PAT 甲级 1046 Shortest Distance(前缀和)

1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

Analysis:

use the prefix sum to calculate the distance  (d1) between a and b(a<b).the answer is the minimum between d1 and sum-d1(sum is the circular distance).

C++:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int n,sum=0;
	cin>>n;
	int d[n+1];
	d[n]=0;
	for(int i=0;i<n;i++){
		cin>>d[i];
		sum+=d[i];// circular distance
	}
	for(int i=1;i<n;i++){
		d[i]=d[i]+d[i-1];//prefix sum 
	}
	int m;
	cin>>m;
	for(int j=0;j<m;j++){
		int a,b,dis1=0,dis2=0;
		cin>>a>>b;
		a--;b--;
		if(a>b){//ensure a<b
			int temp=b;
			b=a;
			a=temp;
		}
		dis1=d[b-1]-d[a-1>=0?a-1:n];//if a-1<0,dis=d[b-1]-0;
		int num=min(dis1,sum-dis1);
		cout<<num<<endl;
	} 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/83686771