【HDU - 1220】Cube (组合数学,简单)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/82418834

题干:

Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points. 

Process to the end of file. 

Input

There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30). 

Output

For each test case, you should output the number of pairs that was described above in one line. 

Sample Input

1
2
3

Sample Output

0
16
297


        
  
The results will not exceed int type.

Hint

Hint
        
 

解题报告:

两个小方块之间的交点个数为0,1,2,4;为了方便计算我们可以用减法,先求出两个方块组合的全部可能情况再减去两个方块相邻(即交点为四个的情况) 
两个方块相邻(交点个数为4):每列有n-1对,每面有n列 每面的个数即为n*(n-1) 
用正方体左,上,前三面计算,也就是两个方块相邻总情况数为3*n*(n-1) 
公式:C(2, n^3) - 3*n*(n-1) = n*n*n*(n*n*n-1)/2 - 3*n*n*n+3*n*n题解源

AC代码:

#include<bits/stdc++.h>

using namespace std;

int main(){
    int n;
    while(~scanf("%d", &n)) {
        printf("%d\n", n*n*n*(n*n*n-1)/2 - 3*n*n*n+3*n*n);
    }
    return 0;
}

在找四个交点(共面)的时候,还有一种理解,相当于是枚举了所共的每一个面

             4个交点的立方体对是两个立方体共面的情况,求出大的立方体一共有多少个单位面积的公共面;

             即所有单位立方体的面数6*n^3减去在大立方体表面的面数6*n^2就可以了

AC代码:

#include<stdio.h>
int main()
{
    int n,m;
    while(~scanf("%d",&n))
    {
        m=(n*n*n*(n*n*n-1)/2)-(6*n*n*n-6*n*n)/2;
        printf("%d\n",m);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/82418834
今日推荐