hdu 1220 Cube(数学)

Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
Output
For each test case, you should output the number of pairs that was described above in one line.
Sample Input

1
2
3

Sample Output

0
16
297




The results will not exceed int type.

两个小方块之间的交点个数为0,1,2,4;为了方便计算我们可以用减法,先求出两个方块组合的全部可能情况再减去两个方块相邻(即交点为四个的情况)
两个方块相邻(交点个数为4):每列有n-1对,每面有n列 每面的个数即为n*(n-1)
用正方体左,上,前三面计算,也就是两个方块相邻总情况数为3*n*(n-1)
公式:C(2, n^3) - 3*n*(n-1) = n*n*n*(n*n*n-1)/2 - 3*n*n*n+3*n*n

#include<cstdio>
using namespace std;

int main(){
    int n, s;
    while(scanf("%d", &n)!=EOF){
        s = n*n*n*(n*n*n-1)/2 - 3*n*n*n+3*n*n;
        printf("%d\n", s);
    }
    return 0;
}

我是个该死的笨蛋,,,忘了加while循环,,,绝望

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/80530825