HDU--1220--数学题目

Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.

Input

There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).

Output

For each test case, you should output the number of pairs that was described above in one line.

Sample Input
1
2
3
Sample Output
0
16
297  
The results will not exceed int type.

思路:数学推论;可能的公共点数目0,1,2,4; ans=all-4个公共点的数目;

all=Cn^3 2=(n^3)*(n^3-1)/2(组合数); 4个公共点的数目=3*n^2*(n-1);

#include<cstdio>
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		printf("%d\n",(n*n*n)*(n*n*n-1)/2-3*n*n*(n-1));
	}
}
发布了170 篇原创文章 · 获赞 73 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104510915