HDU - 4810 Wall Painting(组合数学+枚举)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/GYH0730/article/details/82806611

Wall Painting

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3978    Accepted Submission(s): 1317


Problem Description

Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with different plans.

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?
You should tell Mr.Fang the answer from the first day to the n-th day.

 Input

There are several test cases, please process till EOF.
For each test case, the first line contains a single integer N(1 <= N <= 103).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.

 Output

For each test case, output N integers in a line representing the answers(mod 106 +3) from the first day to the n-th day.

 Sample Input

4 1 2 10 1

 Sample Output

14 36 30 8

 Source

2013ACM/ICPC亚洲区南京站现场赛——题目重现

这道题并不好想啊,训练的时候老想异或的性质了,奇数个1异或为1,偶数个1异或为0,怎么也没把时间复杂度降下来,题解利用到了组合数,把每个数化为2进制,统计每一位二进制所有数1的个数,一位一位的计算和,比如样例:

0 0 0 1

0 0 0 1

1 0 1 0

0 0 1 0

在第2天的时候,答案为 C(1,1) * C(3,1)*(1<<3) + 0 + C(2,1)*C(2,1) * (1<<1)+ C(2,1)*C(2,1) * (1<<0)

利用组合数巧妙的把复杂度降为30n*n了

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int MAXN = 1010;
const int MOD = 1e6 + 3;
int num[35];
ll C[MAXN][MAXN];
//****************预处理出小范围的组合数******************//
void init()
{
    int i, j;
    memset(C, 0, sizeof(C));
    for(i = 0; i < MAXN - 5; i++)
        C[i][i] = C[i][0] = 1;
    for(i = 1; i < MAXN - 5; i++)
    for(j = 1; j < i; j++)
        C[i][j] = (C[i-1][j-1] + C[i-1][j]) % MOD;
}
//****************预处理出小范围的组合数******************//
int main(void)
{
    int n,cnt,t;
    ll tt;
    init();
    while(scanf("%d",&n) != EOF) {
        memset(num,0,sizeof(num));
        for(int i = 1; i <= n; i++) {
            scanf("%d",&t);
            cnt = 0;
            while(t) {
                if(t & 1) num[cnt]++;
                t >>= 1;
                cnt++;
            }
        }
        for(int i = 1; i <= n; i++) {
            ll ans = 0;
            for(int j = 0; j <= 30; j++) {
                for(int k = 1; k <= i; k += 2) {
                    tt = (1ll << j) % MOD * C[num[j]][k] % MOD * C[n - num[j]][i - k] % MOD;
                    ans = (ans + tt) % MOD;
                }
            }
            if(i == n) printf("%I64d\n",ans);
            else printf("%I64d ",ans);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/GYH0730/article/details/82806611