hdu 1220 Cube

传送门

Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.

Input

There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).

Output

For each test case, you should output the number of pairs that was described above in one line.

Sample Input

1
2
3

Sample Output

0
16
297

【题意】

给你一个n*n*n的立方体,问你有多少对立方体,他们的顶点相同数小于等于2.

【分析】

显然可以得到顶点相同数量只能为0,1,2,4.所以我们用容斥来做。直接统计所有的对数,也就是sum*(sum-1)/2。然后减掉有四个顶点的。稍微分析一下就知道有四种情况,分别统计一下就行了。

【代码】

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<cmath>
#include<map>
#include<time.h>
#include<bits/stdc++.h>
using namespace std;
int main()
{
//    freopen("in.txt","w",stdout);
    int a;
    while(cin>>a)
    {
        if(a==1)
        {
            puts("0");
            continue;
        }
        long long sum = a*a*a;
        long long ans = (sum*(sum-1))>>1;
        long long jiao = 8*3;
        long long leng = 12*(a-2)*4;
        long long mian = 6*(a-2)*(a-2)*5;
        long long li = (a-2)*(a-2)*(a-2)*6;
        ans-=(jiao+leng+mian+li)>>1;
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/mengzhongsharen/article/details/79324861