HDU5100 Chessboard【组合数学】

Chessboard

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1434    Accepted Submission(s): 589


 

Problem Description

Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.

Input

There are multiple test cases in the input file.
First line contain the number of cases T (T≤10000). 
In the next T lines contain T cases , Each case has two integers n and k. (1≤n,k≤100)

Output

Print the maximum number of chessboard squares tiled.

Sample Input

2
6 3
5 3

Sample Output

36

24

Source

BestCoder Round #17

问题链接:HDU5100 Chessboard

题解:http://www.matrix67.com/blog/archives/5900

AC的C++程序:

#include<iostream>

using namespace std;

int solve(int n,int k)
{
	if(n<k)  //棋盘还比一个矩阵小返回0 
	  return 0;
	int m=n%k;
	if(m<=k/2)
	  return n*n-m*m;
	else
	  return n*n-(k-m)*(k-m);
}

int main()
{
	int t,n,k;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&k);
		printf("%d\n",solve(n,k));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/81639020
今日推荐