POJ3258 跳石头 二分

题目:

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

/*题意:有一条长度为L的河,除了起点和终点外还有N个石子,分别距离起点距离为 Di,求去掉M个石子后相邻的最小距离
的最大值*/
/*最小距离的最大值*/

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,m,l,low,high,i,mid,num,start;
int a[100005];
int fun(int mid)
{
    int start=0;
    int num=0;
    for(int i=1;i<=n;i++)
    {
        if(a[i]-start<mid)
            num++;
        else
        {
           start=a[i];
        }
    }
    if((l-a[n]<mid)&&a[n]==start)return 0;//最后一跳
    if(num>m)return 0;
    return 1;
}
int main()
{
   while(scanf("%d%d%d",&l,&n,&m)!=EOF)
   {
       int low=0;
       int high=l;
       int mid,ans;
       for(int i=1;i<=n;i++)
       {
           scanf("%d",&a[i]);
       }
       sort(a,a+n+1);//注意排序
       while(low<=high)
       {
           mid=(low+high)/2;
           if(fun(mid))
           {
               ans=mid;//说明最小距离还不够大,还可以优化使之变得更大
               low=mid+1;
           }
           else
            high=mid-1;//说明最小距离过大,不合适
       }
       printf("%d\n",ans);
   }
   return 0;
}

猜你喜欢

转载自blog.csdn.net/rain699/article/details/81784021