poj3258 二分 ʕ •ᴥ•ʔ

River Hopscotch

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 20124   Accepted: 8368

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意:一条长L的河上,除了起点和终点还有N个石子,分别距离起点距离di,求去掉M个石子后相邻的最小距离的最大值

题解:二分搜索结果

#include<stdio.h>
#include<string.h>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll long long
int a,b,c;
int e[50010];
int find(int w)
{
	int ans=0;
	int x=0;
	for(int i=1;i<=b+1;i++)
	{
		if(e[i]-e[x]<w)//如果两点之间距离小于w(mid) 移走这个点 ans++ 
		ans++;
		else
		x=i;//标记上个不被移走石头的位置 
	}
	if(ans<=c)//如果小于等于 则说明 mid值太小了 
	return 1;
	return 0;
}
int main()
{
	cin>>a>>b>>c;
	for(int i=1;i<=b;i++)
	{
		cin>>e[i];
		
	}
	e[0]=0;
	e[b+1]=a;
	sort(e,e+b+1);
	int l=0,r=a;
	ll ans=0;
	while(l<=r)
	{
		int mid=(r+l)/2;
		if(find(mid))
		{
			ans=mid;
			l=mid+1;
		}
		else
		r=mid-1;
	}
	cout<<ans<<endl;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81750812