POJ 3258 -- River Hopscotch(二分)

题目链接

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

AC

  • 二分枚举答案,每次统计当前删除石头的个数,如果个数大于M证明mid偏大,如果个数小于M证明mid偏小,因为要求最大的长度,所以等于的时候和小于的情况相同(l = mid + 1)
#include <iostream>
#include <stdio.h>
#include <map>
#include <vector>
#include <algorithm>
#define N 100005
#define ll long long
using namespace std;
int a[N];
int main() {
#ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
#endif
    int length, n, m;
    scanf("%d%d%d", &length, &n, &m);
    for (int i = 1; i <= n; ++i) {
        scanf("%d", &a[i]);
    }
    a[++n] = length; 
    sort(a + 1, a + 1 + n);
    int l = 1, r = length;
    while (l <= r) {
        int mid = (l + r) >> 1;
        int sum = 0;
        for (int i = 0; i < n; ++i) {
            int len = 0;
            for (int j = i + 1; j <= n; ++j) {
                len = a[j] - a[i];
                if (len >= mid) {
                    len = 0;
                    sum += j - i - 1;
                    i = j - 1;
                    break;
                }
            }
            if (len > 0) {
                sum += n - i;
                break;
            }
        }

        if (sum > m)    r = mid - 1;
        else            l = mid + 1;
    }

    printf("%d\n", r);
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/henuyh/article/details/81736704
今日推荐