POJ3258 River Hopscotch (二分,最小值最大化)

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing Mrocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

代码:

import java.util.Arrays;
import java.util.Scanner;
public class Main {
	static Scanner sc = new Scanner(System.in); 
	static int river[] = new int[50050];
	static int Search(int left, int right, int k,int n) //left right表示的是从0---s要去掉哪一个数字的
	{
		int mid;
		while(left <= right)
		{
			mid = (left + right) >> 1;
			int cnt = 0;//利用当前的石头值能移除的石头个数
			int last = 0; //这个不好理解  表示的是如果 比如 0 2 11 此刻mid = 12 如果取走2 那么还要判断 0--11 之间是否也小于 如果小于 就取掉 如果不小于 那么就更新当前的值把这个当最小的 
			for(int i = 1; i <= n + 1;i++)
			{
				if(mid >= river[i] - river[last])
					cnt++;
				else last = i;
			}
			if(cnt > k) 
				right = mid - 1;
			else 
				left = mid + 1 ;			
		}
		return left;
	}
	public static void main(String[]args)
	{
		int s = sc.nextInt();
		int n = sc.nextInt();
		int m = sc.nextInt();
		for(int i = 1; i <= n; i++)
			river[i] = sc.nextInt();
		river[n + 1] = s;
		river[0] = 0;
		Arrays.sort(river, 0, n + 1);
		System.out.println(Search(0,s,m,n));
	}
}

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/83793215