PAT (Advanced Level) Practice — 1154 Vertex Coloring (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37345402/article/details/87992596

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/1071785301894295552

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

输入一张无向图,给出每个顶点的颜色,如果在一条边上的两个顶点颜色相同则输出No,否则输出颜色的种类。

#include<bits/stdc++.h>
using namespace std;
int main(){
	int n,m;
	int a[11111];
	int b[11111];
	int c[11111];
	int k;
	cin>>n>>m;
	for(int i=0;i<m;i++)
	cin>>a[i]>>b[i];
	map<int,int>p;
	cin>>k;
	while(k--)
	{
		p.clear();
		int sum=0;
		for(int i=0;i<n;i++)
		{
			cin>>c[i];
			if(p[c[i]]==0)
			{
				sum++;
				p[c[i]]=1;
			}
		}
		int f=1;
		for(int i=0;i<m;i++)
		{
			if(c[a[i]]==c[b[i]])
			{
				f=0;
				break;
			}
		}
		if(f)
		{
			cout<<sum<<"-coloring"<<endl;
		}
		else{
			cout<<"No"<<endl;
		} 
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/m0_37345402/article/details/87992596