nyoj 211 Cow Contest

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_27437781/article/details/71194265

Cow Contest

时间限制:1000 ms  |  内存限制:65535 KB
难度:4
描述

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

输入
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

There are multi test cases.The input is terminated by two zeros.The number of test cases is no more than 20.
输出
For every case:
* Line 1: A single integer representing the number of cows whose ranks can be determined
样例输入
5 5
4 3
4 2
3 2
1 2
2 5
0 0
样例输出
2
来源

USACO 2008 January Silver



题意:给你n头牛,每头牛都有自己的kills值,和其他牛的都不同,然后kills大的可以赢小的。现在给出n头牛的比赛结果,问你有几头牛可以确定排名。

如果A>B,B>C,那么A>C,所以这道题我们要用到floyd的闭包传递。


AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cstring>
#define INF 0x3f3f3f3f
using namespace std;
int map[101][101];

int main()
{
    int n, m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        memset(map, 0, sizeof(map));
        for(int i = 1; i <= m; i++)
        {
            int x, y;
            scanf("%d%d",&x,&y);
            map[x][y] = 1;
        }
        for(int k = 1; k <= n; k++)
        {
            for(int i = 1; i <= n; i++)
            {
                for(int j = 1; j <= n; j++)
                {
                    if(map[i][k]&&map[k][j])
                    {
                        map[i][j] = 1;
                    }
                }
            }
        }
        int c1 = 0, c2 = 0;
        int ans = 0;
        for(int i = 1; i <= n; i++)
        {
            c1 = 0, c2 = 0;
            for(int j = 1; j <= n; j++)
            {
                if(map[i][j])
                    c1++;
                if(map[j][i])
                    c2++;
            }
            if(c1+c2==n-1)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/qq_27437781/article/details/71194265