cow contest(floyd 传递闭包)

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2


题意:

在已知部分大小关系的基础上,推断有几个排名确定。

Ps:

当一个点与其他所有点的关系确定,他的排名就确定。用Floyd即可算出。

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int N=110;
int mmp[N][N];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int u,v;
        memset(mmp,0,sizeof(mmp));
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&u,&v);
            mmp[u][v]=1;
        }
        for(int k=1; k<=n; k++)
            for(int i=1; i<=n; i++)
                for(int j=1; j<=n; j++)
                    if(mmp[i][k]&&mmp[k][j])
                        mmp[i][j]=1;
        int ans=0,j;
        for(int i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(i==j) continue;
                if(mmp[i][j]==0&&mmp[j][i]==0) break;
            }
            if(j>n) ans++;
        }
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_40510246/article/details/80174546