(最短路)Cow Contest

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include<queue>
using namespace std;
const int maxn=101;
const int inf=0x3f3f3f3f;
int edge[maxn][maxn],n,t,m;
int main()
{
	int i,j,k;
	while(~scanf("%d%d",&n,&m))
	{
		int a,b;
		memset(edge,0,sizeof(edge));
		for(i=1;i<=m;i++) 
		{
			scanf("%d%d",&a,&b);
			edge[a][b]=1;
		}
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				for(k=1;k<=n;k++)
				{
					if(edge[j][i]==1&&edge[i][k]==1) edge[j][k]=1;
				}
			}
		}
		int ans=0;
		for(i=1;i<=n;i++)
		{
			int num=0;
			for(j=1;j<=n;j++)
			{
				if(edge[i][j]==1) num++;
				if(edge[j][i]==1) num++;
			}
			if(num==n-1) ans++;
		}
		printf("%d\n",ans);
	}
}

猜你喜欢

转载自blog.csdn.net/zufe_cst/article/details/82716518