Cow Contest POJ - 3660 floyd

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

floyd判联通 也有dfs的写法 map[i][j]之间是联通的那就表明他们之间确立了强弱关系

#include<iostream>
#include<cstring>
using namespace std;
int map[120][120];
int n,m;

void floyd()
{
	for(int k=1;k<=n;k++)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(map[i][k]==1&&map[k][j]==1) //如果联通就是可以 确定排名 
				map[i][j]=1;
			}
		}
	}
}

int main()
{
	ios::sync_with_stdio(false);
	while(cin>>n>>m)
	{
		memset(map,0,sizeof(map));
		int ans=0;
		if(!n||!m)
		{
			break;
		}
		for(int i=1;i<=m;i++)
		{
			int s,e;
			cin>>s>>e;
			map[s][e]=1;
		}
		floyd();
		for(int i=1;i<=n;i++)
		{
			int cnt=0;
			for(int j=1;j<=n;j++)
			{
				if(map[i][j]==1||map[j][i]==1)
				{
					cnt++;
				}
			}
			ans=ans+((cnt==n-1)?1:0);
		} 
		cout<<ans<<endl;
	}
}
扫描二维码关注公众号,回复: 3403253 查看本文章

猜你喜欢

转载自blog.csdn.net/weixin_41544329/article/details/82670918