H - Cow Contest POJ - 3660

H - Cow Contest

POJ - 3660

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2
//#include<bits/stdc++.h>
#define _CRT_SBCURE_NO_DEPRECATE
#include <set>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
//#define UP(i,x,y) for(int i=x;i<=y;i++)
//#define DOWN(i,x,y) for(int i=x;i>=y;i--)
#define sd(x,y,z) scanf("%d%d%d", &x, &y, &z)
//#define sd(x,y) scanf("%d%d%d", &x, &y)
#define pb push_back
#define long long ll
using namespace std;
const int maxn = 1010;
const int INF = 0x3f3f3f3f;

int n, m;
struct edge
{
    int to;
    int cost;
    edge(int t,int c):to(t),cost(c){}
    //edge(int t, double c):to(t),cost(c){}

};
int G[maxn][maxn];
int sum[maxn];
void init()
{
    for(int i = 1; i <= n; ++i)
    {
        for(int j = 1; j <= n; ++j)
        {
            if(i==j)
                G[i][j] = 0;
            else
                G[i][j] = INF;
        }
    }
}
void floyd()
{
    for(int k = 1; k <= n; ++k)
    {
        for(int i = 1; i <= n; ++i)
        {
            for(int j = 1; j <= n; ++j)
            {
                if(G[i][j] > G[i][k] + G[k][j])
                {
                    G[i][j] = G[i][k] + G[k][j];
                }
            }
        }
    }
}
int main()
{
    //freopen("in.txt", "r", stdin);
	while(~scanf("%d%d", &n, &m))
    {
        init();
        int ta, tb;
        for(int i = 0; i < m; ++i)
        {
            scanf("%d%d", &ta, &tb);
            G[ta][tb]=1;
        }
        floyd();
        int ans = 0;
        memset(sum, 0, sizeof sum);
        for(int i = 1; i <= n; ++i)
        {
            for(int j = 1; j <= n; ++j)
            {
                if(G[i][j] < INF && G[i][j])
                {
                    sum[i]++;
                    sum[j]++;
                }
            }
        }
        for(int i = 1; i <= n; ++i)
        {
            if(sum[i] == n-1)
                ans++;
        }
        printf("%d\n",ans);
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40758751/article/details/81429324