HDU 3763 CD(二分)

CD

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1257    Accepted Submission(s): 545

 

Problem Description

Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?

Neither Jack nor Jill owns more than one copy of each CD.

Input

The input consists of a sequence of test cases. The first line of each test case contains two non-negative integers N and M, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by N lines listing the catalog numbers of the CDs owned by Jack in increasing order, and M more lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.

Output

For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.

Sample Input

3 3 1 2 3 1 2 4 0 0

Sample Output

2

Source

University of Waterloo Local Contest 2010.09.26

Recommend

notonlysuccess

 看两个人的cd种类相同的有几个

因为数据太大,用二分查找 相同 ++ ,

#include <iostream>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;
#define N 1001000
#define ll long long
int n,m;
int a[N];
int halfsearch(int key,int n)
{
    int low=0,high=n-1,mid;
    while(low<=high)
    {
        mid=(low+high)/2;
        if(a[mid]==key)
            return 1;
        else if(a[mid]<key)
            low=mid+1;
        else
            high=mid-1;
    }
    return 0;
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>m)
    {
        if(n==0&&m==0) break;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        ll b;
        int cnt=0;
        for(int i=0;i<m;i++)
        {
            cin>>b;
            if(halfsearch(b,n)) cnt++;
        }cout<<cnt<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/81745573