HDU1025-LIS+二分

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28936    Accepted Submission(s): 8197


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
 

Sample Input
 
  
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
 
  
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.

题意:意思就是,输入一个数字n,表示有多少条线,在线线之间不交叉的情况下,最多能有多少条线。

思路:输入的时候要用scanf,数据太多了500K。然后就可以用最长上升子序列来做,求的是后面的子序列,因为数据是500K,所以要用到二分法(不用输出子序列来,只要输出长度就可以了)。

坑点:输出是很大的一个坑点,首先输出之间有换行,这个换行在每个数据都是有的,然后就是那个roads那个单词,当线的数量大于1的时候要加s。输入的时候样例顺序是递增的,不要以为所有样例都是递增的,这是一个坑点。就这几个地方坑了好久

AC代码:


#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=500100;
const int INF=0x7f7f7f7f;
int num[maxn];
int array[maxn];
int main()
{
    int n,i,j,k,m,q;
    k=1;
    while (scanf("%d",&n)!=EOF)
        {
            for (i=1;i<=n;i++)
                {
                    scanf("%d%d",&m,&q);
                    num[m]=q;
                }
            int Max=1;array[1]=num[1];
            int low,high,mid;
            for (i=2;i<=n;i++)
                {
                    low=1;high=Max;
                    while (low<=high)
                        {
                            mid=(low+high)>>1;
                            if (num[i]<=array[mid])
                                high=mid-1;
                            else low=mid+1;
                        }
                    array[low]=num[i];
                    if (Max<low)
                        Max=low;
                }
            printf("Case %d:\n",k++);
            printf("My king, at most %d road",Max);
            if (Max>1)
                printf("s");
            printf(" can be built.\n");
            printf("\n");
        }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/z1164754004z/article/details/80998853