HDU - 2819(二分图匹配)

Given an N*N matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?

Input

There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N*N matrix.

Output

For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”.

Sample Input

2
0 1
1 0
2
1 0
1 0

Sample Output

1
R 1 2
-1

思路:如果这是个完全匹配,说明有解。因为这说明每一行中都可以对应一列。

#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
int n,x,y,mpp[110][110],vis[110],dis[110],cut,a[110],b[110];
int found(int v)
{
    for(int i=1; i<=n; i++)
    {
        if(mpp[v][i]&&!vis[i])
        {
            vis[i]=1;
            if(!dis[i]||found(dis[i]))
            {
                dis[i]=v;
                return 1;
            }
        }
    }
    return 0;
}
void see()
{
    for(int i=1; i<=n; i++)
        printf("%d ",dis[i]);
    printf("\n");
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(dis,0,sizeof(dis));
        memset(mpp,0,sizeof(mpp));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&mpp[i][j]);
            }
        }
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            memset(vis,0,sizeof(vis));
            if(found(i)) ans++;
        }
        if(ans!=n)
        {
            printf("-1\n");
            continue;
        }
        cut=0;
//        see();
        for(int k=1; k<=n; k++)
            for(int i=1; i<=n; i++)
            {
                if(dis[i]!=i)
                {
                    a[cut]=i;
                    b[cut++]=dis[i];
                    int u=dis[i];
                    dis[i]=dis[u];
                    dis[u]=u;
                }
            }
        printf("%d\n",cut);
        for(int i=0; i<cut; i++)
        {
            printf("C %d %d\n",a[i],b[i]);
        }
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/81224454