HDU - 2473 并查集删点

Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0

Sample Output

Case #1: 3
Case #2: 2

题目大意:给你一些点和操作,操作分两种,一种是把某两个点连到一个连通块里,一种是把某个点从所在的连通块里删掉。最后问一共有几个连通块。

分析:并查集的连通很好写,普通的连通操作就可以;删点操作就不好实现了,我们这里采取一个连虚根的办法,就是一开始把所有的点 i 都连到点 i+n 上,对于 n 之后的点 fa[] 值都赋为自己, 要删点的时候就把 fa[i] 的值改为一个新的点,之前在连通块里的点不去管它了。最后的答案找到所有的根节点即可。

代码:

#include <iostream>
#include <cstdio>
#include <set>
#include <stdio.h>
using namespace std;

int fa[5000005];

int father(int x){
	if (x==fa[x]) return x;
	else {
		fa[x]=father(fa[x]);
		return fa[x];
	}
}

bool vis[5000005];
int main()
{
	int n,m,x,y,l,u=0;
	char c;
	while (scanf("%d%d", &n, &m)!=EOF){
		u++;
		if (n==0 && m==0) break;
		l=2*n;
		for (int i = 0; i < n; i++) fa[i]=i+n;   //设立虚根

		for (int i = n; i < n+n+m; i++){
			fa[i]=i;   //最多可能有n+n+m个点
			vis[i]=0;
		}
		for (int i = 0; i < m; i++)
		{
			getchar();
			c=getchar();
			if (c=='M')
			{	
				scanf("%d%d", &x, &y);
				int r1=father(x), r2=father(y);
				if (r1!=r2)
				{
					fa[r1]=r2;
				}
			}
			else{
				scanf("%d", &x);
				fa[x]=l;    //删点操作
				l++;
			}
		}
		int ans=0;
		for (int i = 0; i < n; i++)
		{
			int r1=father(i);      //找到根节点
			if (!vis[r1])
			{
				vis[r1]=1;   //已经找到过的连通块标记为1
				ans++;       //计数器加1
			}
		}
		printf("Case #%d: %d\n", u, ans);
	}
	return 0;
}
扫描二维码关注公众号,回复: 2844132 查看本文章

猜你喜欢

转载自blog.csdn.net/qq_41703679/article/details/81783285