HDU2473Junk-Mail Filter(并查集的删点)经典

HDU2473Junk-Mail Filter(并查集的删点)经典

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6526    Accepted Submission(s): 2093

 

Problem Description

Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

 

5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0

Sample Output

 

Case #1: 3 Case #2: 2

Source

2008 Asia Regional Hangzhou 

#include<stdio.h>
 
const int N = 2000005;
int fath[N],vist[N],n;
 
void init()
{
    for(int i=0;i<n;i++)
        fath[i]=i+n; //1~n设一个虚节点,相当于虚点是实点,1~n实点成了虚点
    for(int i=n; i<2*n;i++)
        fath[i]=i,vist[i]=0;
}
int findfath(int x)
{
    if(x!=fath[x])
        fath[x]=findfath(fath[x]);
    return fath[x];
}
void setfath(int x,int y)
{
    x=findfath(x);
    y=findfath(y);
    fath[x]=y;
}
int main()
{
    int m,k,a,b,c=0;
    char str[5];
    while(scanf("%d%d",&n,&m)>0&&m+n!=0)
    {
        init();
        k=2*n;
        while(m--)
        {
            scanf("%s%d",str,&a);
            if(str[0]=='M')
            {
                scanf("%d",&b);
                setfath(a,b);
            }
            else
            {
                fath[a]=k; fath[k]=k; vist[k]=0; k++; //点a从点集合中分离出来,同样需设一个虚点
            }
        }
        int ans=0; //点集个数
        for(int i=0;i<n;i++)
        {
            a=findfath(i);
            if(vist[a]==0)
            {
                ans++; vist[a]=1;
            }
        }
        printf("Case #%d: %d\n",++c,ans);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_42173193/article/details/81741090