Junk-Mail Filter HDU - 2473(带删除的并查集)

Junk-Mail Filter     HDU - 2473

Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0

Sample Output

Case #1: 3
Case #2: 2

代码:  带删除的并查集  M 合并 xy  S 删除 x

#include<bits/stdc++.h>
using namespace std;
const int maxn = 2e6+10; 
int n,m;
int food[maxn],box[maxn];
int vis[maxn];
int find(int x){
	while(x != box[x])
	{
		int r = box[x];
		box[x] = box[r];
		x = r;
	}
	return x;
}
void merge(int x,int y)
{
	int fx = find(x);
	int fy = find(y);
	if(fx != fy){
		box[fx] = fy;
	}
	return ;
}
void Apart(int x,int t)
{

	return ;
}
int main()
{
	int cas = 0;
	while(scanf("%d %d",&n,&m) != EOF)
	{
		if(n == 0 && m == 0)
			return 0;
		char str[5];
		int x, y, t = n; //t表示虚根 
		for(int i = 0 ; i < n; i++)
			food[i] = i, box[i] = i;
		while(m--)
		{
			scanf("%s",str);
			if(str[0] == 'M')
			{
				scanf("%d %d",&x,&y);
				merge(food[x], food[y]);
			}
			else 
			{
				scanf("%d",&x);
				food[x] = t;
				box[t] = t;
				t++;
			}
		}
		for(int i = 0 ; i <= t; i++)
			vis[i] = 0;
		int ans = 0;
		for(int i = 0 ; i < n; i++)
		{
			if(vis[find(food[i])] == 0)
			{
				vis[find(food[i])] = 1;
				ans++;
			}	
		}
		printf("Case #%d: %d\n",++cas,ans);	
	}	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/83894282