HDU - 2473 Junk-Mail Filter

版权声明:如果转载,请注明出处。 https://blog.csdn.net/S_999999/article/details/82014819

Recognizing junk mails is a tough task. The method used here consists of two steps: 
1) Extract the common characteristics from the incoming email. 
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam. 

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations: 

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so 
relationships (other than the one between X and Y) need to be created if they are not present at the moment. 

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph. 

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N. 
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file. 
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above. 
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0

Sample Output

Case #1: 3
Case #2: 2
//并查集删除点,不能直接修改父亲节点的值,因为这样相当于,并入了一个新节点。
//我们可以 用一个过渡节点(有点函数映射的意思),过渡节点必须要大于n,否则不是过渡节点。
//具体看代码
#include<bits/stdc++.h>
using namespace std;
int father[2000010],vis[2000010];
int id;
int find(int x){
	if(x!=father[x])
	    return father[x] = find(father[x]);
      return father[x];
}
int main(void){
	
	int n,m;
	char op ;
	int k =1;
	while(scanf("%d%d",&n,&m)!=EOF&&(n||m)){
	     
	   for(int i = 0; i < n; ++i)            //注意,题目中 i 是从0开始的
			father[i] = i + n;               //设置过渡父节点 
		for(int i = n; i <= n + n + m; ++i)//n+n+m: 最多可能删除m个节点
			father[i] = i;

	      id = n + n;// 删除节点,就是把父节点改为id  相当于又设置了一个过渡节点
		  for(int i =1;i<=m;i++){
		    getchar();
		 	scanf("%c",&op);
		 	
		 	if(op=='M'){
		 	 int x,y;
		 	 scanf("%d%d",&x,&y);
		 	 int fx = find(x);
		 	 int fy = find(y);
			 if(fx != fy)
			  	father[fx] = fy;
			   	
			 }
		 	else {
		 		int x;
		 		scanf("%d",&x);
		 		father[x] = id++;
			 }
		 	
		 	
		 }
		
		memset(vis,0,sizeof(vis));
		int ans=0;
		for(int i =0;i<n ;i++){
	          
	          int f = find(i);
			  if(!vis[f]){
			  	 ans++;
				 vis[f] = 1; 
			  } 
	            
		 }
	    
	    printf("Case #%d: %d\n",k++,ans);
	    
	}
	
	
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/S_999999/article/details/82014819