hdu 2473 Junk-Mail Filter 并查集删点,模板题

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10376    Accepted Submission(s): 3280


Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 
Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 
Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 
Sample Input
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 
Sample Output
Case #1: 3 Case #2: 2
 
Source
 
 
这道题就是一个简单的并查集删点题,
用了虚父节点来进行删除操作,也是许久以来第一次做并查集删除题目吧。
然后点一下要出现的几个坑,
1,数组开小了会炸(这次会tle),数组要开 最大点*2+最大操作数
2,初始化的范围,着重注意一下是从0开始下标还是从1开始下标,比较重要最好一致
 
上代码
 
#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>

using namespace std; 

int n,m,cur_delete;
const int maxn = 10000;
const int maxm = 100000;
int data[maxn*2 + maxm + 100];
int book[maxn*2 + maxm + 100];

void Init(){
    for(int i = 0;i < n;i++){
        data[i] = i+n;
    }
    for(int i = n;i < n + n + m;i++){
        data[i] = i;
    }
}

int Found(int n0){
    if(data[n0] != n0)
        data[n0] = Found(data[n0]);
    return data[n0];
}

void Merge(int n1,int n2){
    int f1 = Found(n1);
    int f2 = Found(n2);
    if(f1 != f2){
        data[f1] = f2;
    }
    return;
}

void Delete(int n0){
    data[n0] = cur_delete++;
    return;
}

int main(){
    char str[10];int a,b,cur_case = 0;
    while(scanf("%d%d",&n,&m) != EOF&&n + m != 0){
        cur_delete = n*2;
        Init();
        for(int i = 0;i <m;i++){
            scanf("%s",str);
             if(str[0] == 'M'){
                scanf("%d%d",&a,&b);
                Merge(a,b);
            }
            else if(str[0] == 'S'){
                scanf("%d",&a);
                Delete(a);
            }
        }
        
        int ans = 0;int curbook; 
        memset(book,0,sizeof(book));
        for(int i = 0;i < n;i++){
             curbook = Found(i);
             if(book[curbook] == 0){
                 book[curbook] = 1;
                 ans++;
             }
        }
        printf("Case #%d: %d\n",++cur_case,ans);
    }
    
    
    return 0;
}
就酱~~~~~~~~~~~

猜你喜欢

转载自www.cnblogs.com/xuyanqd/p/9028426.html