并查集删点+虚根父亲节点 HDU 2473 Junk-MailFilter

Junk-MailFilter

TimeLimit: 15000/8000 MS (Java/Others)    Memory Limit:32768/32768 K (Java/Others)
Total Submission(s): 10406    Accepted Submission(s): 3290

ProblemDescription

Recognizing junk mails is a tough task.The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted todetermine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junkemails available at the moment, and thus having a handy data-analyzing toolwould be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y arethe same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if theyare not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool shouldremove all relationships that spam X has when this command is received; afterthat, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so thenumber of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

 

 

Input

There are multiple test cases in the inputfile.
Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤M ≤ 106), the number of email samples and the number of operations.M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 andM = 0 indicates the end of the input file, and should not be processed by yourprogram.

 

 

Output

For each test case, please print a singleinteger, the number of distinct common characteristics, to the console. Followthe format as indicated in the sample below.

 

 

SampleInput

5 6

M 0 1

M 1 2

M 1 3

S 1

M 1 2

S 3

3 1

M 1 2

0 0

 

 

SampleOutput

Case #1:3

Case #2:2

 

 

Source

2008Asia Regional Hangzhou

 

 

Recommend

Lcy

算法分析:

并查集删点问题,一开始想直接把该删点的的父亲节点改变了,不就行了,但一想并查集的特性,可能会导致所有的父亲的节点都改变,所以行不同。这里边虚父亲节点了。

以一个例子讲解:

5 6

M 0 1

M 1 2

M 1 3

S 1

 具体实现看代码,

代码实现:

 

#include<bits/stdc++.h>
using namespace std;
#define N 1200000
int fa[N];
bool vis[N];
int find(int x)
{
    //cout<<x<<" "<<fa[x]<<endl;
    return x==fa[x]?x:fa[x]=find(fa[x]);
}
int main()
{
   int n,m;
    int o=0;
    while(scanf("%d%d",&n,&m)!=EOF)
    {

        if(n==0&&m==0) break;

        int k=2*n;
        for(int i=0;i<n;i++)//序号从0开始
            fa[i]=n+i;
        for(int i=n;i<n*2+m+1;i++)
            fa[i]=i;
//固定根节点,n+1~n+n作为根节点,而1~n作为虚拟根节点(指向n+1~n+n),之后在增添n+n~n+n+m作为备用节点
        for(int i=0;i<m;i++)
        {
           char s[4];
            scanf("%s",s);

            if(s[0]=='M')
            {
                int x,y;
                scanf("%d %d",&x,&y);
                int r1=find(x),r2=find(y);

                if(r1!=r2)
                {
                    fa[r1]=r2;
                }
            }
            else if(s[0]=='S')
            {//删除时直接修改1~n指向的节点到n+n后的节点
                int x;
                scanf("%d",&x);
                fa[x]=k++;
            }
        }
        int ans=0;
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)
        {
            int t=find(i);
            if(!vis[t])
            {
                vis[t]=1;
                ans++;
            }
        }
         printf("Case #%d: %d\n",++o,ans);
    }

   return 0;
}

猜你喜欢

转载自blog.csdn.net/sdz20172133/article/details/80374488