HDU-2473 Junk-Mail Filter(并查集的使用)

原题链接:https://vjudge.net/problem/11782/origin

Description:

Recognizing junk mails is a tough task. The method used here consists of two steps: 
1) Extract the common characteristics from the incoming email. 
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam. 

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations: 

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so 
relationships (other than the one between X and Y) need to be created if they are not present at the moment. 

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph. 

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N. 
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file. 
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above. 
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0

Sample Output

Case #1: 3
Case #2: 2

题意:有n个点,M a,b代表a,b是一个集合,S a代表从集合中删除a点,经过m个指令后,最后输出有几个集合。

题解:本题是学习并查集的好题,题意很简单(hdu和codeforces的题意比uva上的好懂多了。。。),M指令相当于并查集中的集合合并函数,S指令需要自己补充函数,此题关键是初始化时不能像并查集那样将自己设为父结点,而是应该设置虚拟父结点。话不多说,AC代码如下:

#include <queue>
#include <iostream>
#include <vector>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
#include <string>
#include <sstream>
#include <string.h>
#include <stdio.h>
#include <time.h>
using namespace std;
#define fast                                ios::sync_with_stdio(0);cin.tie(0);cout.tie(0);
#define ll                                  long long
#define _for(i,a,b)                         for(int i = a;i < b;i++)
#define rep(i,a,b)                          for(int i = a;i <= b;i++)
#define all(s)                              s.begin(), s.end()

const int maxn = 1e5 + 100;
const int maxm = 1e6 + 100;
int n, m,ans=0,flag,a,b;

int par[2*maxn+maxm];
//初始化时虚拟父结点为n个
//S删除指令后,被删除的元素需要重新获得一个虚拟父结点(最多有1e6个)

char cmd[2];

int find_(int x) { // 寻找树的根
	if (par[x] == x) {
		return x;
	}
	else {
		return par[x] = find_(par[x]); // 直接连向祖先结点, 查找的时候可以省时间
	}
}
void unite(int x, int y)
{ // 合并 x 和 y 所在的集合
	x = find_(x); // 寻找祖先
	y = find_(y); // 寻找祖先
	if (x == y) return;
	else par[y] = x;
}
void del(int x)
{
	par[x] = flag++;
}

int main()
{
	int kase = 1;
	while ((scanf("%d%d", &n, &m) == 2) && n)
	{
		_for(i, 0, n) 
			par[i] = i + n;//虚拟父结点
		_for(i, n, n + n + m)
			par[i] = i;//初始化虚拟父结点

		flag = n + n;//用于S后的虚拟父结点的赋值

		while (m--)
		{
			scanf("%s", cmd);
			if (cmd[0] == 'M')//合并
			{
				scanf("%d%d", &a, &b);
				unite(a, b);
			}
			else//删除
			{
				scanf("%d", &a);
				del(a);
			}
		}
		map<int, int>vis;
		ans = 0;
		_for(i, 0, n)//遍历
		{
			int x = find_(i);
			if (!vis.count(x))//新集合
			{
				ans++;
				vis[x]++;
			}
		}
		printf("Case #%d: %d\n", kase++, ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42098718/article/details/81603599