Brainman 归并排序求逆序对

Raymond Babbitt drives his brother Charlie mad. Recently Raymond counted 246 toothpicks spilled all over the floor in an instant just by glancing at them. And he can even count Poker cards. Charlie would love to be able to do cool things like that, too. He wants to beat his brother in a similar task.

Problem
Here's what Charlie thinks of. Imagine you get a sequence of N numbers. The goal is to move the numbers around so that at the end the sequence is ordered. The only operation allowed is to swap two adjacent numbers. Let us try an example:

Start with: 2 8 0 3
swap (2 8) 8 2 0 3
swap (2 0) 8 0 2 3
swap (2 3) 8 0 3 2
swap (8 0) 0 8 3 2
swap (8 3) 0 3 8 2
swap (8 2) 0 3 2 8
swap (3 2) 0 2 3 8
swap (3 8) 0 2 8 3
swap (8 3) 0 2 3 8


So the sequence (2 8 0 3) can be sorted with nine swaps of adjacent numbers. However, it is even possible to sort it with three such swaps:

Start with: 2 8 0 3
swap (8 0) 2 0 8 3
swap (2 0) 0 2 8 3
swap (8 3) 0 2 3 8


The question is: What is the minimum number of swaps of adjacent numbers to sort a given sequence?Since Charlie does not have Raymond's mental capabilities, he decides to cheat. Here is where you come into play. He asks you to write a computer program for him that answers the question. Rest assured he will pay a very good prize for it.

Input

The first line contains the number of scenarios.
For every scenario, you are given a line containing first the length N (1 <= N <= 1000) of the sequence,followed by the N elements of the sequence (each element is an integer in [-1000000, 1000000]). All numbers in this line are separated by single blanks.

Output

Start the output for every scenario with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the minimal number of swaps of adjacent numbers that are necessary to sort the given sequence. Terminate the output for the scenario with a blank line.

Sample Input

4
4 2 8 0 3
10 0 1 2 3 4 5 6 7 8 9
6 -42 23 6 28 -100 65537
5 0 0 0 0 0

Sample Output

Scenario #1:
3

Scenario #2:
0

Scenario #3:
5

Scenario #4:
0

题目大意:有一个长为n的数组,想把它变成有序的,每次只能交换相邻的两个数字,问最少交换几次?

通过观察样例,可以发现答案刚好是数组里的逆序对的个数,可以用归并排序求解。归并排序的原理是每次把两个有序的子序列合并为一个序列,那么我们只要在合并的时候记录一下逆序对的个数就可以了。具体实现的时候,如果右边的数字小于左边的数字,那么左边的序列从当前位置到最后的所有数字一定都大于右边的这个数字,逆序对就有mid-p+1个。

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

int ans=0, a[1005], c[1005], n;

void cal(int l , int r)
{
	int p, q, mid, len;

	mid = (l+r) >> 1;
	if (l==r) return;
	cal(l, mid);
	cal(mid+1, r);
	p=l; q=mid+1; 
	len = r-l+1;
	for (int i = 0; i < len; i++)
	{
		if ((q>r)||(a[p]<=a[q] && p<=mid))
		{
			c[l+i] = a[p];
			p++;
		}
		else{
			c[l+i] = a[q];
			q++;
			ans += mid-p+1;
		}
	}

	for (int i = l; i <= r; i++) {
		a[i] = c[i];
	}
}

int main()
{
	int t;
	scanf("%d", &t);
	for (int u = 1; u <= t; u++)
	{
		scanf("%d", &n);
		for (int i = 1; i <= n; i++) scanf("%d", &a[i]);
		ans = 0;
		cal(1, n);
		printf("Scenario #%d:\n%d\n", u, ans);
		if (u<t)
		{
			printf("\n");
		}
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41703679/article/details/81634903