[归并排序]Brainman

Description

Background 
Raymond Babbitt drives his brother Charlie mad. Recently Raymond counted 246 toothpicks spilled all over the floor in an instant just by glancing at them. And he can even count Poker cards. Charlie would love to be able to do cool things like that, too. He wants to beat his brother in a similar task. 

Problem 
Here's what Charlie thinks of. Imagine you get a sequence of N numbers. The goal is to move the numbers around so that at the end the sequence is ordered. The only operation allowed is to swap two adjacent numbers. Let us try an example: 
Start with: 2 8 0 3 
swap (2 8) 8 2 0 3 
swap (2 0) 8 0 2 3 
swap (2 3) 8 0 3 2 
swap (8 0) 0 8 3 2 
swap (8 3) 0 3 8 2 
swap (8 2) 0 3 2 8 
swap (3 2) 0 2 3 8 
swap (3 8) 0 2 8 3 
swap (8 3) 0 2 3 8

So the sequence (2 8 0 3) can be sorted with nine swaps of adjacent numbers. However, it is even possible to sort it with three such swaps: 
Start with: 2 8 0 3 
swap (8 0) 2 0 8 3 
swap (2 0) 0 2 8 3 
swap (8 3) 0 2 3 8

The question is: What is the minimum number of swaps of adjacent numbers to sort a given sequence?Since Charlie does not have Raymond's mental capabilities, he decides to cheat. Here is where you come into play. He asks you to write a computer program for him that answers the question. Rest assured he will pay a very good prize for it.

Input

The first line contains the number of scenarios. 
For every scenario, you are given a line containing first the length N (1 <= N <= 1000) of the sequence,followed by the N elements of the sequence (each element is an integer in [-1000000, 1000000]). All numbers in this line are separated by single blanks.

Output

Start the output for every scenario with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the minimal number of swaps of adjacent numbers that are necessary to sort the given sequence. Terminate the output for the scenario with a blank line.

Sample Input

4
4 2 8 0 3
10 0 1 2 3 4 5 6 7 8 9
6 -42 23 6 28 -100 65537
5 0 0 0 0 0

Sample Output

Scenario #1:
3

Scenario #2:
0

Scenario #3:
5

Scenario #4:
0

 

思路:归并排序求逆序数;

AC代码:

#include <iostream>
#include<cstdio>
#define N 1005
using namespace std;

int ans=0;
int a[N];

void merge_(int l,int m,int r){
  int tmp[N],cnt=0;
  int i,j;
  for(i=l,j=m+1;i<=m&&j<=r;){
    if(a[i]<=a[j]) {tmp[++cnt]=a[i]; i++;}
    else{
        tmp[++cnt]=a[j]; j++;
        ans+=(m-i+1);//求逆序数
    }
  }
  while(i<=m) {tmp[++cnt]=a[i]; i++;}
  while(j<=r) {tmp[++cnt]=a[j]; j++;}
  for(int i=l,j=1;i<=r&&j<=cnt;i++,j++) a[i]=tmp[j];
}

void merge_sort(int l,int r){
  if(l==r) return;
  if(l<r){
    int m=(l+r)>>1;
    merge_sort(l,m);
    merge_sort(m+1,r);
    merge_(l,m,r);
  }
}

int main()
{
    int t;
    scanf("%d",&t);
    for(int k=1;k<=t;k++){
      int n; scanf("%d",&n);
      for(int i=1;i<=n;i++) scanf("%d",&a[i]);
      ans=0;
      merge_sort(1,n);
      printf("Scenario #%d:\n%d\n\n",k,ans);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/lllxq/p/9079185.html
今日推荐