2018杭电多校暑假 Maximum Multiple hdoj6298

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 967    Accepted Submission(s): 445

 

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

 

Sample Input

3 1 2 3

Sample Output

-1 -1 1

题解:  ∣ 这是能否被整除的情况,这道题一开始先打表看看有没有规律,仔细一看还真有,被3整除的答案是n*n*n/27,能被4整除的答案n*n*n/32,其他情况都是-1  其实1=1/3+1/3+1/3  1=1/2+1/4+1/4  且又是求最大值,也就这几种情况

code:

#include <bits/stdc++.h>

typedef long long LL;
using namespace std;


int main() {
    ios::sync_with_stdio(false);
    cin.tie(nullptr);
    LL T, n;
    cin >> T;
    while (T--) {
        cin >> n;
        LL ans = 0;
        if (n % 3 == 0) {
            ans = (n / 3) * (n / 3) * (n / 3);
        } else if (n % 4 == 0) {
            ans = (n / 4) * (n / 4) * (n / 2);
        } else
            ans = -1;
        cout << ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/remarkableyan/article/details/81182362