HDU - 6298 Maximum Multiple(思维)

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 286    Accepted Submission(s): 113


 

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

 

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

 

Sample Input

 

3

1

2

3

 

Sample Output

 

-1

-1

1

 

Source

2018 Multi-University Training Contest 1

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6308 6307 6306 6305 6304 

 

#include<bits/stdc++.h>
using namespace std;
#define LL long long

const int MAXN = 1e6+10;
const int INF = 0x3f3f3f3f;
const int N = 1010;
const int MOD = 1e9+7;

LL n,t;
int main(){
    scanf("%lld",&t);
    while(t--){
        scanf("%lld",&n);
        LL ans = 0;
        if(n%3==0){
            ans = (n/3)*(n/3)*(n/3);
        }
        else{
            if(n%4==0){
                ans = (n/2)*(n/4)*(n/4);
            }
            else ans = -1;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/l18339702017/article/details/81174453