2018杭电多校赛第一场1001Maximum Multiple

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0

 

Problem Description

Given an integer n , Chiaki would like to find three positive integers x , y and z such that: n=x+y+z , x∣n , y∣n , z∣n and xyz is maximum.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106 ), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106 ).

Output

For each test case, output an integer denoting the maximum xyz . If there no such integers, output −1 instead.

Sample Input

 

3 1 2 3

Sample Output

 

-1 -1 1

x∣n ,  |整除符号,即n=kx

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{

    
    long long int t,n;
    long long int b, a, c;
    long long int max=0;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&n);
        if (n%3==0)
        {
            a=n/3;
            max=a*a*a;
            printf("%lld\n",max);
        }
        else if(n%4==0)
        {
            a=n/2;
            b=n/4;
            max=a*b*b;
            printf("%lld\n",max);
        }
        else
            printf("-1\n");    
    }
}

猜你喜欢

转载自blog.csdn.net/dovis233/article/details/81174756