A - Maximum Multiple HDU - 6298

 2018 Multi-University Training Contest 1

A - Maximum Multiple 

Given an integer nn, Chiaki would like to find three positive integers xx, yy and zzsuch that: n=x+y+z, x∣nx∣n, y∣ny∣n, z∣nz∣n and xyzxyz is maximum. 

Input

There are multiple test cases. The first line of input contains an integer TT (1≤T≤1061≤T≤106), indicating the number of test cases. For each test case: 
The first line contains an integer nn (1≤n≤1061≤n≤106). 

Output

For each test case, output an integer denoting the maximum xyzxyz. If there no such integers, output −1−1 instead. 

Sample Input

3
1
2
3

Sample Output

-1
-1
1

x+y+z=n  若(x>=y>=z)

令a=1/x   b=1/y  c=1/z;

则1<=a<=3

a=1不可能的。

a=2 :b=4 c=4或 b=3  c=6;

a=3 :b=3 c=3;(包含了上面第二种)

所以只有这两种情况成立啦!

其他都是-1……


#include<cstdio>
#include<iostream>
using namespace std;

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        scanf("%d",&n);
        if(n%3==0)
        {

            printf("%I64d\n", 1ll *n*n*n/27);
        }
        else if(n%4==0)
            printf("%I64d\n", 1ll *n*n*n/32);
        else
            printf("-1\n");
    }
    return 0;
}
发布了19 篇原创文章 · 获赞 3 · 访问量 1395

猜你喜欢

转载自blog.csdn.net/xuanhuangwendao/article/details/81214066
今日推荐