HDU 2018暑假多校第一场 A Maximum Multiple

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0

 

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

Sample Input

3 1 2 3

Sample Output

-1 -1 1

思路:

条件:

1. x∣n, y∣n, z∣n    可整除的3个因子

2.n=x+y+z

So,我们阔以得出(小学弟弟好厉害呀嘤嘤嘤被吊打嘤嘤嘤):

1.n/3+n/3+n/3=n

2.n/2+n/4+n/4=n

3.n/2+n/3+n/6=n  (满足3一定满足1,难以使xyz最大,舍去(惊了

#include <cstdio>

int main()
{
	long long t;
	long long n;

	scanf("%d",&t);
	while(t--){
		scanf("%lld",&n);
		if(n%3==0) printf("%lld\n",n*n*n/27);
		else if(n%4==0) printf("%lld\n",n*n*n/32);
		else printf("-1\n");
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/daddy_hong/article/details/81173365