HDU 6298 Maximum Multiple(找规律)

版权声明:转载请标明出处哦 https://blog.csdn.net/PleasantlY1/article/details/82112965

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

Sample Input

 

3

1

2

3

Sample Output

 

-1

-1

1

题目大意:给出一个n,求a,b,c要求n能够整除a,b,c且a+b+c=n,输出a*b*c最大的情况。

思路:这道题让我学会了一个技巧,遇事不决先打表(Get√)。

打表如图:然后发现,能出解的情况只有能被3.4整除的数,当能被3整除时,abc相等,当能被4整除且不被3整除时a=2b=2c。

代码如下:

#include<set>
#include<map>
#include<list>
#include<deque>
#include<cmath>
#include<queue>
#include<string>
#include<vector>
#include<stdio.h>
#include<sstream>
#include<stdlib.h>
#include<string.h>
#include<ext/rope>
#include<iostream>
#include<algorithm>
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
#define per(i,a,b) for(int i=a;i<=b;++i)
#define max(a,b)  a>b?a:b
#define min(a,b)  a<b?a:b
#define LL long long 
//#define swap(a,b) {int t=a;a=b;b=t} 
using namespace std;
using namespace __gnu_cxx;
int main()
{
    long long int n,t,i,j,maxn=0;;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld",&n);
        if(n%3==0&&n>2)
        {
            printf("%lld\n",(n/3)*(n/3)*(n/3));
        }
        else if(n%4==0&&n>2)
        {
            printf("%lld\n",(n/4)*(n/4)*(n/4)*2);
        }
        else printf("-1\n");       
    }
    return 0; 
}

猜你喜欢

转载自blog.csdn.net/PleasantlY1/article/details/82112965
今日推荐