hdu 6298 Maximum Multiple

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3985    Accepted Submission(s): 926

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

Sample Input

3 1 2 3

Sample Output

-1 -1 1

n=x+y+z, x∣n, y∣n, z∣n

的意思是:x+y+z=n,且x.y,z都能被n整除

只要能被3或4整除就可以了

#include <bits/stdc++.h>
#define  ll long long
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll n;
        scanf("%lld",&n);
        if(n<3)
        {
            printf("-1\n");
            continue;
        }
        if(n%3==0)
        {
            ll temp=n/3;
            printf("%lld\n",temp*temp*temp);
            continue;
        }
        if(n%2==1)
        {
            printf("-1\n");
            continue;
        }
        if(n%4==0)
        {
            ll temp=n/2;
            ll temp1=n/4;
            printf("%lld\n",temp*temp1*temp1);
            continue;
        }
        printf("-1\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81227463
今日推荐