A multiplication game POJ - 2505 (博弈+找规律)

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
Input
Each line of input contains one integer number n.
Output
For each line of input output one line either 
Stan wins. 
or 
Ollie wins. 
assuming that both of them play perfectly.
Sample Input
162
17
34012226
Sample Output
Stan wins.
Ollie wins.
Stan wins.

题意:p总是从1 开始 , S和O两人轮流将P乘以2~9任意一个数 , 谁先大于等于n(1 < n < 4294967295)谁赢 , S总是先进行。

手推: 0 ~ 9 S必赢

           10 ~ 18   ( 2*9 )  O必赢(2是Stan,他要尽量阻止Ollie取到n;9是Ollie,他要尽量大来取到n

            19 ~ 81     ( 2* 9 *9 ) S必赢

             。。。。。。。

注意用double

#include <stdio.h>
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
	double n;
	while(~scanf("%lf" , &n))
	{
		while(n > 18)n /= 18;
		if(n <= 9)
		{
			printf("Stan wins.\n");
		}
		else
		{
			printf("Ollie wins.\n");
		}
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/qq_41593380/article/details/80075059