F - Truck History

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/危(to,td)d(to,td) 


where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4

aaaaaaa

baaaaaa

abaaaaa

aabaaaa

0

Sample Output

The highest possible quality is 1/3.

  • 题意概括  :

给你n个字符串,每个字符串代表一种卡车类型,字符串的不同字母的个数代表两种类型之间的距离,求出最短的距离。

  • 解题思路  :

首先在输入的时候直接比较两个字符串不同字母的个数,用一个变量记录下来然后存入map数组中,然后直接prim算法求最短路。

#include<stdio.h>
#include<string.h>

char str[2010][10];
int map[2010][2010],dis[2010],book[2010];
int n,inf = 99999999;
int prim()
{
	int i,j,k,count=0,sum=0,min;
	memset(book,0,sizeof(book));
	for(i = 1;i<=n;i ++)
	{
		dis[i] = map[1][i];
	}
	book[1] = 1;
	count ++;
	while(count < n)
	{
		min = inf;
		j = 0;
		for(i =1;i<=n;i ++)
		{
			if(book[i] == 0&&dis[i] < min)
			{
				min = dis[i];
				j = i;
			}
		}
		book[j] = 1;
		count ++;
		sum += dis[j];
		for(k = 1;k<=n;k ++)
		{
			if(book[k] == 0&&dis[k] > map[j][k])
			{
				dis[k] = map[j][k];
			}
		}
	}
	return sum;
}
int main()
{
	int i,j,k,t;
	
	while(~ scanf("%d",&n))
	{
		if(n == 0)
		break;
		for(i = 1;i<=n;i ++)
		{
			scanf("%s",str[i]);
			for(j = 1;j<=i;j ++)
			{
				t = 0;
				for(k = 0;k<7;k ++)
				{
					if(str[i][k]!=str[j][k])
					t ++;
					map[i][j] = map[j][i] = t;
				}
			}
		}
		printf("The highest possible quality is 1/%d.\n",prim());
	}
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81333158