poj 1789 Truck History 【prim+转化】

版权声明:转载的时候记着点个赞再评论一下! https://blog.csdn.net/LOOKQAQ/article/details/82760594

题目链接:http://poj.org/problem?id=1789

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 33967   Accepted: 13142

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

题意:任意两个字符串(不妨看作两个节点)不相同的字符数目为节点之间的权值,现在让你把这些节点全部连通需要的最小的代价。

思路:我是用prim()算法来实现的,其实kruskal算法也可以,个人爱好!代码如下:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 2e3+10;
const int inf = 0x3f3f3f3f;
int vis[maxn],dis[maxn],dis1[maxn][maxn],n,ans1;
char map1[maxn][maxn],str[maxn][10];
void prim()  //prim算法的核心部分
{
    memset(dis,inf,sizeof dis);
    memset(vis,0,sizeof vis);
    for(int i=1;i<=n;i++)
        dis[i]=dis1[1][i];
    vis[1] = 1;
    dis[1] = 0;
    int ans,next;
    ans1=0;
    for(int i=1;i<n;i++)
    {
        ans=inf;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && dis[j] < ans)
            {
                ans = dis[j];
                next = j;
            }
        }
        vis[next] = 1;
        ans1+=ans;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && dis[j] > dis1[next][j])
                dis[j] = dis1[next][j];
        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n && n)
    {
        for(int i=1;i<=n;i++)
            cin>>map1[i];
        memset(dis1,0,sizeof dis1);
        for(int i=1;i<=n;i++)  //这三种循环依次算出点i和点j的距离
        {
            for(int j=i+1;j<=n;j++)
            {
                for(int k=0;k<7;k++)
                {
                    if(map1[i][k] != map1[j][k])
                    {
                        dis1[i][j]++;
                        dis1[j][i]++;
                    }
                }
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(!dis1[i][j])  //如果成立,则i和j之间的距离为无穷大
                    dis1[i][j] = inf;
            }
        }
        prim();
        cout<<"The highest possible quality is "<<"1/"<<ans1<<'.'<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/LOOKQAQ/article/details/82760594