F - Truck History POJ - 1789

F - Truck History

POJ - 1789

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

题意:这题题意好难理解啊。生产很多车,车的型号会由其他车衍生过来,每个型号用7个字符表示,第一个是不能由其他型号衍生的。然后衍生的权值为两种型号间不同的字符的个数。求最小衍生的权值。建好图后之间prim就可以了。

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 2100;
int g[maxn][maxn],d[maxn],vis[maxn],n;
char str[maxn][10];

int wight(int i,int j)
{
    int ans = 0;
    for(int k = 1;k <= 7;k++)
    {
        if(str[i][k] != str[j][k])
            ans++;
    }
    return ans;
}

int prim()
{
    memset(d,inf,sizeof(d));
    memset(vis,0,sizeof(vis));
    d[1] = 0;

    int sum = 0;
    while(1)
    {
        int v = - 1;
        for(int u = 1;u <= n;u++)
        {
            if(!vis[u] && (v == -1 || d[v] > d[u])) v = u;
        }
        if(v == -1) break;
        vis[v] = 1;
        sum += d[v];
        for(int u = 1;u <= n;u++)
        {
            if(!vis[u]) d[u] = min(d[u],g[v][u]);
        }
    }
    return sum;
}

int main()
{
    while(scanf("%d",&n) && n)
    {
        for(int i = 1;i <= n;i++)
        {
            scanf("%s",str[i] + 1);
        }
        for(int i = 1;i <= n;i++)
        {
            for(int j = i + 1;j <= n;j++)
            {
                g[i][j] = g[j][i] = wight(i,j);
            }
        }
        int ans = prim();
        printf("The highest possible quality is 1/%d.\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Eric_chen_song_lin/article/details/82748913