Truck History prime

题目表述:

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that t ois the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

输入:

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

输出:

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

样例输入:

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

样例输出:

The highest possible quality is 1/3.

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define maxn 2500
#define maxx 0x3f3f3f3f
int n,a,ans;
char s[maxn][8];//注意这个地方一定要定义成char型,别习惯性的定义成int
int lowchang[maxn],vis[maxn];
int juli(int x,int y)//用来表示不同类型卡车之间的距离
{
    int sum=0;
    for(int i=0;i<7;i++)
    {
        if(s[x][i]!=s[y][i])
            sum++;
    }
    return sum;
}
void prime()
{
     ans=0;
    for(int i=1;i<=n;i++)
    {
        lowchang[i]=juli(1,i);//到i的最小距离最初定义成i到1的距离
        vis[i]=0;
    }
    vis[1]=1;
    for(int i=1;i<=n;i++)//循环N次,找到每一个lowchang[i]
    {
        int min=maxx;

        for(int j=1;j<=n;j++)
        {
            if(lowchang[j]<min && !vis[j])//选择权值最小的
            {
                min=lowchang[j];
                a=j;
            }
        }

        vis[a]=1;
        for(int i=1;i<=n;i++)
        {
            if(juli(a,i)<lowchang[i]&&!vis[i])//每个点到已经在集合里的点最小值,本来都是每个点都1的,如果现在2也加入的话,那就是每个点到2的与每个点到1的比较,要那个最小的
            {
                lowchang[i]=juli(a,i);

            }
        }
    }
    ans=0;
    for(int i=1;i<=n;i++)//上面for循环结束后,所有的lowchang[i]的最小值都确定下来,相加

    {
        ans+=lowchang[i];
    }

}

int main()
{
    while(scanf("%d",&n)!=EOF &&n)
    {
        getchar();
        for(int i=1;i<=n;i++)
        {
            scanf("%s",s[i]);
        }
        prime();
printf("The highest possible quality is 1/%d.\n",ans);
 }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/zhangjinlei321/article/details/81290148