POJ1789-Truck History

Truck History
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 31889   Accepted: 12436

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

        学校ACM比赛的一道题,当时看了半天没看懂,,,略尴尬尴尬,后来看了一些大神博客,发现是一道很简单的最小生成树的题,唉~可惜了。说一下题意吧:一共n个字符串,每两个字符串(即顶点)之间的距离为两个字符串之间不相同的位的数目,如(aaaaaaa)和(abaaaaa)之间距离为1,只有第二个字符不相同。下面是代码↓↓↓↓↓

#include <stdio.h>
#define N 2010

char str[N][8];
int low[N];
int map[N][N];

//求第x个串与第y个串之间的距离 
int getDis( int x , int y ){
	int cnt = 0,k;
	for( int k=0 ; k<7 ; k++ ){ 
		if( str[x][k]!=str[y][k] )
			cnt++;		
	} 
	return cnt;
}

//普里姆算法求最小生成树 
int prim( int n ){
	int min,pos,sum,i,j;
	for( i=0 ; i<n ; i++ ){
		low[i] = map[0][i];
	}
	sum = 0;
	for( i=1 ; i<n ; i++ ){
		min = 0x3f3f3f3f;
		for( j=0 ; j<n ; j++ ){
			if( low[j]!=0 && min>low[j] )
				min = low[ pos=j ];
		}
		sum += low[pos];
		low[pos] = 0;
		for( j=0 ; j<n ; j++ ){
			if( low[j]!=0 && low[j]>map[pos][j] )
				low[j] = map[pos][j];
		}
	}
	return sum;
}

int main(){
	int n,i,j;
	while( ~scanf( "%d",&n ) && n ){
		for( i=0 ; i<n ; i++ ){
			scanf( "%s",str[i] );
			map[i][i] = 0;
			for( j=0 ; j<i ; j++ ){
				map[i][j] = map[j][i] = getDis( i,j );
			}
		}
		printf( "The highest possible quality is 1/%d.\n",prim(n) );
	}
}

如有其他看法,欢迎交流~

猜你喜欢

转载自blog.csdn.net/revenant_di/article/details/80272668