POJ - 1789 Truck History 最小生成树

一、内容

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types. 

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan. 

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

二、思路

  • 一辆车可以派生出其他类型的车,花费的代价是2个类型字符的不同个数。 那么就可以每两两类型建立一条边, 权值为不同字符的个数。 最后求最小生成树即可。

三、代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 2005;
int n, g[N][N], d[N];
bool vis[N];
char s[N][8];
int getD(int i, int j) {
	int ans = 0;
	//求不同字符的数量 
	for (int x = 0; x < 7; x++) ans += s[i][x] != s[j][x];
	return ans;
}
int prime() {
	memset(d, 0x3f, sizeof(d));
	memset(vis, false, sizeof(vis));
	int ans = 0;
	for (int i = 0; i < n; i++) {
		int t = -1;
		for (int j = 1; j <= n; j++) {
			if (!vis[j] && (t == -1 || d[t] > d[j])) t = j;
		}
		vis[t] = true; //加入集合
		if (i) ans += d[t]; //如果不是第一个点
		for (int j = 1; j <= n; j++) d[j] = min(d[j], g[t][j]); 
	}
	return ans;
}
int main() {
	while (~scanf("%d", &n), n) {
		for (int i = 1; i <= n; i++) scanf("%s", s[i]);
		for (int i = 1; i <= n; i++) {
			for (int j = i + 1; j <= n; j++) {
				g[i][j] = g[j][i] = getD(i, j);
			}
		}
		printf("The highest possible quality is 1/%d.\n", prime()); 
	}
	return 0; 
}
发布了414 篇原创文章 · 获赞 380 · 访问量 6万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/104233077