Truck History(prim)

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

 理解题意是关键!!

题意:给出n个长度为7的字符串,每个字符串代表一个车,定义车的距离是两个字符串间不同字母的个数,题目要求的数不同的车的距离的最小值,即所求的就是最小生成树。

要加工n辆车,第一种车是已知的;(也可以想到,后面的车生产没有先后顺序)

剩下的车由生产过的车派生。(可以理解为第三辆车可以由第二辆车派生也可以由第一辆车派生)

求改动最小(可以理解为花费最小),利用最小生成树模板。

 思路:对于两个车牌号,相同位置上若对应值不同两者差异值就加1,这样计算出车牌号两两间的差异值,求用最小的差异值之和遍历所有车牌号,记这个和是s,并输出1/s,生成一棵最小生成树,算出s,用Prim算法水过

实现代码:

#include<stdio.h>
#include<string.h>
char str[2010][10];
int map[2010][2010],dis[2010],book[2010];
int n,inf=99999999;
int prim()/*最小生成树的模板*/
{
	int i,j,k,sum=0;
	int count=0,min;
	memset(book,0,sizeof(book));
	for(i=1;i<=n;i++)
	{
		dis[i]=map[1][i];
	}
	book[1]=1;
	count++;/*第一辆车直接加上我们从这里开始*/
	while(count<n)/*结束的条件放while里面*/
	{
		min=inf;
		int u=0;/*记录一下那个最小值是哪条边*/ 
		for(i=1;i<=n;i++)
		{
			if(book[i]==0&&dis[i]<min)
			{
				min=dis[i];
				u=i;
			}
		}
		book[u]=1;
		count++;
		sum+=dis[u];
		for(k=1;k<=n;k++)
		{
			if(book[k]==0&&dis[k]>map[u][k])
			{
				dis[k]=map[u][k];
			}
		}
	} 
	return sum;
	
}
int main()
{
	int i,j;
	while(~scanf("%d",&n),n)/*这里n为零跳出*/
	{
		for(i=1;i<=n;i++)
		{
			scanf("%s",str[i]);/*这里输入的是样本输入*/
			for(j=1;j<=i;j++)
			{
				int t=0;
				for(int k=0;k<7;k++)
				{
					if(str[i][k]!=str[j][k])
					t++;/*相同位置上若对应值不同两者的差异值*/
					map[i][j]=map[j][i]=t;/*把样本输入转换成熟悉的数字形式。*/
				}
			}
		}
		printf("The highest possible quality is 1/%d.\n",prim());
	}
	return 0;
}

prim算法入门题:

1.https://blog.csdn.net/with_wine/article/details/113972924

2.https://blog.csdn.net/with_wine/article/details/113722148

猜你喜欢

转载自blog.csdn.net/with_wine/article/details/113980197