poj 1860 判断正权回路

Currency Exchange

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 36113   Accepted: 13861

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103. 
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102. 
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104. 

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题意:这里有N种货币,分别记为1~N,有M种货币交换的方式,每一种方式有A,B两种钱币,有RAB, CAB, RBA and CBA,四个数,表示交换率, Nick手上有其中的一种货币S,货币S的钱数为V,问你能否通过一定次数的钱币交换让Nick手中的钱增加,那么循环无数次之后一定是可以赚回本钱的,至于有些人循环一圈之后就与本金比是否增大是不可取的,因为万一转为本金的佣金很高,但是存在一个一次增加一点点的正环的话就需要循环很多次才可以高于本金。

这道题目看了很长时间还是没看懂题目,看了一些博客发现大部分是用bellman-ford进行求解,也有用Floyd来做的,其实这道题算是求最短路的模板思想,个人感觉Dijkstra也可以,不过还没试,下面我将两种代码附上

Floyd:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<iomanip>
using namespace std;
#define rep(i,a,b)  for(int i=a;i<=b;i++)
int n,m,s;
double v;
double map[105];//用来存到达每个城市所剩下的钱数
double R[105][105],c[105][105];//分别表示汇率与费用,用二维数组表示,注意是double类型
int floyd()
{
	double d[105];
	rep(i,1,n)
	d[i]=map[i];//这里的数组是看循环n/2遍是否大于原来的钱数
	rep(k,1,n/2)//这里主要是将这个图多次循环,保证那种增长速度慢的多次经过后钱数能够增加,n次                        //                                                                            循环也行
	rep(i,1,n)
	rep(j,1,n)
	{
	    if((map[i]-c[i][j])*R[i][j]>map[j])//判断是否经过该城市钱数增加
            map[j]=(map[i]-c[i][j])*R[i][j];
	}
	rep(i,1,n)
	if(d[i]<map[i])//只要有一个城市的钱数是大于以前的就满足题意
        return 1;
    return 0;
}
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    cin>>n>>m>>s>>v;
    rep(i,1,m)
    {
        int a,b;
        cin>>a>>b;
        cin>>R[a][b]>>c[a][b]>>R[b][a]>>c[b][a];
    }
    map[s]=v;//从s城市有v的钱数;
    floyd();
    if(floyd())
        cout<<"YES"<<endl;
    else
        cout<<"NO"<<endl;
    return 0;
}

下面是bellmen 的算法,其实两种算法都是判断正权回路的,同样也都能判断负权回路

#include<iostream>
#include<cstring>
using namespace std;
#define rep(i,a,b)  for(int i=a;i<=b;i++)
typedef long long ll;
int n,m,s;
int tot;
double dis[305];
struct node{
    int star;
    int finish;
    double c;
    double r;
}num[305];
int a,b;
double rab,v,cab,rba,cba;
bool output()
{

    bool f=0;
    rep(k,1,n-1){
    f=1;
    for(int i=0;i<tot;i++)
    {
        if(dis[num[i].finish]<((dis[num[i].star]-num[i].c)*num[i].r))
        {
            dis[num[i].finish]=(dis[num[i].star]-num[i].c)*num[i].r;
            f=0;
        }
    }
        if(f)
            break;
}
    rep(i,0,tot-1)
    if(dis[num[i].finish]<((dis[num[i].star]-num[i].c)*num[i].r))
        return true;
    return false;
}
int main()
{
    cin>>n>>m>>s>>v;
            memset(dis,0,sizeof(dis));
            tot=0;
          for(int i=0;i<m;i++)
		{
			cin>>a>>b>>rab>>cab>>rba>>cba;
			num[tot].star=a;
			num[tot].finish=b;
			num[tot].r=rab;
			num[tot++].c=cab;
			num[tot].star=b;
			num[tot].finish=a;
			num[tot].r=rba;
			num[tot++].c=cba;
		}
    dis[s]=v;
    if( output() )
        cout<<"YES"<<endl;
    else
         cout<<"NO"<<endl;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/81385309