SPFA判定正环-Currency Exchange POJ - 1860

SPFA判定正环-Currency Exchange POJ - 1860

题目:
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES

题意:
输入货币种类的数量N(点的数量),货币兑换点(银行?)的数量M(边的数量),所持货币种类S(起点),初始货币数V
输入M行:两种货币的种类a、b、a->b的汇率、a->b的手续费、b->a的汇率、b->a的手续费。
判断最终能否通过一系列兑换使得所持货币总量增加。

思路:
SPFA判定正环,同负环类似,细节上做一些调整。------《SPFA判定负环

代码:

#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define inf 0x3f3f3f
using namespace std;
int N,M,S,k=0;
const int maxn=1e3+5;
const int maxm=1e3+5;
double V,d[maxm];//数组d[i]存储在i处所拥有的货币数量
int head[maxn],cnt[maxn];
bool vis[maxn];
struct node
{
    int v,next;
    double e,c;
}a[maxn];
void add(int u,int v,double e,double c)
{
    a[++k].next=head[u];
    a[k].v=v;
    a[k].e=e;
    a[k].c=c;
    head[u]=k;
}
bool spfa()
{
    memset(d,-inf,sizeof(d));//要货币尽量多,初始化d为-inf
    memset(vis,false,sizeof(vis));
    memset(cnt,0,sizeof(cnt));
    d[S]=V;//初始拥有的货币
    cnt[S]++;
    queue<int> q;
    q.push(S);
    while(q.size())
    {
        int u=q.front();
        q.pop();
        vis[u]=false;
        for(int i=head[u];i;i=a[i].next)
        {
            int v=a[i].v;
            double e=a[i].e,c=a[i].c;//wt
            double val=(d[u]-c)*e;//val的计算的是当前起点的货币
            if(d[v]<val)//d[v]即当前终点的货币
            {
                d[v]=val;
                if(!vis[v])
                {
                    cnt[v]++;
                    if(cnt[v]>N) return true;
                    vis[v]=true;
                    q.push(v);
                }
            }
        }
    }
    if(d[S]>V) return true;//即使无正环,若跑完货币增值依然满足题意
    return false;
}

int main()
{
    scanf("%d%d%d%lf",&N,&M,&S,&V);
    for(int i=0;i<M;i++)
    {
        int u,v;
        double e,c;
        scanf("%d%d%lf%lf",&u,&v,&e,&c);
        add(u,v,e,c);
        scanf("%lf%lf",&e,&c);
        add(v,u,e,c);
    }
    if(spfa()) cout<<"YES"<<endl;
    else cout<<"NO"<<endl;
    return 0;
}


发布了20 篇原创文章 · 获赞 0 · 访问量 560

猜你喜欢

转载自blog.csdn.net/njuptACMcxk/article/details/104023378