Currency Exchange POJ - 1860 最短路径(bellman-ford算法变形 ,正环判断)

  • Currency Exchange

题目链接:http://poj.org/problem?id=1860

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3. 
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2. 
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4. 

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题意:我们的城市有几个货币兑换点。让我们假设每一个点都只能兑换专门的两种货币。可以有几个点,专门从事相同货币兑换。每个点都有自己的汇率,外汇汇率的A到B是B的数量你1A。同时各交换点有一些佣金,你要为你的交换操作的总和。在来源货币中总是收取佣金。 例如,如果你想换100美元到俄罗斯卢布兑换点,那里的汇率是29.75,而佣金是0.39,你会得到(100 - 0.39)×29.75=2963.3975卢布。 你肯定知道在我们的城市里你可以处理不同的货币。让每一种货币都用唯一的一个小于N的整数表示。然后每个交换点,可以用6个整数表描述:整数a和b表示两种货币,a到b的汇率,a到b的佣金,b到a的汇率,b到a的佣金。 nick有一些钱在货币S,他希望能通过一些操作(在不同的兑换点兑换),增加他的资本。当然,他想在最后手中的钱仍然是S。帮他解答这个难题,看他能不能完成这个愿望。 

思路:此题可以看成是求判断是否存在正环,再加上图中可能存在负环,所以考虑在Bellman-Ford算法的基础之上进行修改变形。将原来判断负环的部分改为正环的判断。

扫描二维码关注公众号,回复: 5374508 查看本文章

在松弛的部分判断一下是否存在变大的路径,若不存在,则可以直接得出答案。否则还需在进行正环的判断。

AC代码:

16ms

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<vector>
#define ll long long
const int INF = 0x3f3f3f3f;
const int MAXN = 1000000 + 5;
using namespace std;
int n, m, z;
double y;
double dist[MAXN];
//double map[110][110];
struct edge{
	int st,end;
	double cost,change;
}e[110];
//int visit[110];
//void dijkstra(int x);
bool Bellman_Ford(int st, double cnt, int tol);
int main()
{
	scanf("%d%d%d%lf", &n, &m, &z, &y);
	int k = 0;
	for (int i = 1; i <= m; ++i) {
		int a, b;
		double c, d;
		k++;
		scanf("%d%d%lf%lf%lf%lf", &a, &b, &e[k].change, &e[k].cost, &c, &d);
		e[k].st = a;
		e[k].end = b;
		k++;
		e[k].st = b;
		e[k].end = a;
		e[k].change = c;
		e[k].cost = d;
	}
	if (Bellman_Ford(z, y, k))
		printf("YES\n");
	else
		printf("NO\n");

}

bool Bellman_Ford(int st,double cnt,int tol) {
	for (int i = 1; i <= n; ++i) {
		dist[i] = 0;
	}
	dist[st] = cnt;
	for (int j = 1; j < n; ++j) {
		bool flag = false;
		for (int i = 1; i <= tol; ++i) {
			int x = e[i].st, y = e[i].end;
			if (dist[y] < (dist[x] - e[i].cost)*e[i].change) {
				dist[y] = (dist[x] - e[i].cost)*e[i].change;
				flag = true;
			}
		}
		if (!flag)
			return false;
	}
	for (int i = 1; i <= tol;++i) {
		int x = e[i].st, y = e[i].end;
		if (dist[y] < (dist[x] - e[i].cost)*e[i].change)
			return true;
	}
	return false;
}

猜你喜欢

转载自blog.csdn.net/weixin_43821265/article/details/86596624