【POJ 1860 --- Currency Exchange】Bellman-Ford, 正权环路

【POJ 1860 --- Currency Exchange】Bellman-Ford, 正权环路

题目来源:点击进入【POJ 1860 — Currency Exchange】

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

解题思路

通过dis数组存储转换成s类型后的价值。
根据给定的货币转换建立有向图。
使用Bellman-Ford算法对有向图进行松弛。
初始化时将dis[s]=v;
最后判断松弛后的dis[s]是否大于v。若是代表存在正权环路(即可以使其价值更高)。

但是这个题A了后,我想了想判断最好是通过遍历来判断。

AC代码:

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
const int MAXN = 105;
const int inf = 0x3f3f3f3f;
int n,m,s,num=0;
double v,dis[MAXN];

struct Node
{
    int from,to;
    double r,c;
}node[MAXN<<1];

bool bellman()
{
    memset(dis,0,sizeof(dis));
    dis[s]=v;
    while(true)
    {
        bool flag=false;
        for(int i=0;i<num;i++)
            if(dis[node[i].to]<(dis[node[i].from]-node[i].c)*node[i].r)
                dis[node[i].to]=(dis[node[i].from]-node[i].c)*node[i].r,flag=true;;
        if(!flag) break;
    }
    if(dis[s]>v)  return true;
    return false;
}

int main()
{
    SIS;
    int x,y;
    double r1,r2,c1,c2;
    cin >> n >> m >> s >> v;
    for(int i=0;i<m;i++)
    {
        cin >> x >> y >> r1 >> c1 >> r2 >> c2;
        node[num].from=x;
        node[num].to=y;
        node[num].r=r1;
        node[num++].c=c1;
        node[num].from=y;
        node[num].to=x;
        node[num].r=r2;
        node[num++].c=c2;
    }
    if(bellman()) cout << "YES" << endl;
    else cout << "NO" << endl;
    return 0;
}
发布了412 篇原创文章 · 获赞 135 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/104084930