小白算法练习 计算几何 叉积 直线与直线的交点

Intersecting Lines

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18388   Accepted: 7855

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT
》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》》
#include<iostream>
#include<cstdio>
using namespace std;
struct Point{
	double x,y;
}p1,p2,p3,p4;
struct Line{
	Point h;
	Point t;
}l1,l2;
int cj(Point p1,Point p2,Point p3)
{
	int ans=((p3.x-p1.x)*(p3.y-p2.y)-(p3.x-p2.x)*(p3.y-p1.y));
	if(ans==0) return 0;
	else
	{
		if(ans>0) return 1;
		else return -1;
	}
}
int ispara(Point p1,Point p2,Point p3,Point p4)
{
	int ans=((p2.x-p1.x)*(p4.y-p3.y)-(p2.y-p1.y)*(p4.x-p3.x));
	if(ans==0) return 1;
	else return 0; 
}
int main()
{
	int T;scanf("%d",&T);
	printf("INTERSECTING LINES OUTPUT\n");
	while(T--)
	{
		scanf("%lf %lf %lf %lf",&p1.x,&p1.y,&p2.x,&p2.y);
		scanf("%lf %lf %lf %lf",&p3.x,&p3.y,&p4.x,&p4.y);
		if(cj(p1,p2,p3)==0 && cj(p1,p2,p4)==0)
		{
			printf("LINE\n");
		}
		else if(ispara(p1,p2,p3,p4))
		{
			printf("NONE\n");
		}
		else
		{
			double A=p2.x-p1.x;
			double B=p4.x-p3.x;
			double C=p2.y-p1.y;
			double D=p4.y-p3.y;
			double X=(A*B*p4.y-A*D*p4.x+B*C*p2.x-A*B*p2.y)/(B*C-A*D); 
			double Y;
			if(A!=0)
				Y=(C/A*X)+p2.y-(C/A*p2.x);
			else
				Y=(D/B*X)+p4.y-(D/B*p4.x);
			printf("POINT %.2f %.2f\n",X,Y);
		}
	}
	printf("END OF OUTPUT\n");
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_36336522/article/details/81393392